Cisco Catalyst vs HPE 5700 Link Aggregation

glitchlist Blog Leave a Comment

When you try to connect via Port Channeling Catalyst and HPE switches you should choose the same Link Aggregation protocol. HPE speak LACP, Cisco as a native language speaks PAGP but gets along well with LACP.

To activate LACP under Cisco interface you have to usechannel-group [n] mode active command. HPE use instead link-aggregation mode dynamic under Bridge-Aggregation interface.

# Cisco
#  PortChannel Conf
#
interface Port-channel9
 description LACP to HPE
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10,20,30,40
 switchport mode trunk
 spanning-tree bpdufilter enable
#
#  interfaces Conf
#
interface GigabitEthernet1/0/9
 description LINK Port-channel9 to HPE
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10,20,30,40
 switchport mode trunk
 channel-group 9 mode active
#

# HPE
#  Bridge-Aggregation Conf
#
interface Bridge-Aggregation9
 description LACP to CISCO
 port link-type trunk
 port trunk permit vlan 10,20,30,40
 link-aggregation mode dynamic
 stp edged-port
 mad enable
#
#  interfaces Conf
#
interface GigabitEthernet2/0/9
 description LINK Bri-Aggr.9 to CISCO
 port link-type trunk
 port trunk permit vlan 10,20,30,40 
 stp edged-port
 port link-aggregation group 9

bye!

.glitchlist crew

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.