Cisco 3750X & VMware

glitchlist Uncategorized 6 Comments

If you have to connect VMware server to a Cisco 3750X Stack via Port-Channel consider this:

  • In Cisco, the default PVID is 1
  • In a Cisco trunk the PVID pass untagged
  • VMware virtual switch tag VLAN 1 on a trunk
  • Default channel-group is EtherChannel

So if you pass many VLAN (id. 1 included) on a trunk interface this is the simplest way:

!
vlan 4001
 name VLAN-TRICK
!
interface Port-channel22
 description Etherchannel to VMwareLAB01 * 2Gbps
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 4001
 switchport trunk allowed vlan 1,10,20,30,40,50-60,300
 switchport mode trunk
 switchport nonegotiate
!
interface GigabitEthernet1/0/20
 description Eth0 - VMwareLAB01
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 4001
 switchport trunk allowed vlan 1,10,20,30,40,50-60,300
 switchport mode trunk
 spanning-tree portfast trunk
 channel-group 22 mode on
!
interface GigabitEthernet2/0/20
 description Eth1 - VMwareLAB01
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 4001
 switchport trunk allowed vlan 1,10,20,30,40,50-60,300
 switchport mode trunk
 spanning-tree portfast trunk
 channel-group 22 mode on
!

In this case, we set the native VLAN on a “parking VLAN” so the Cisco trunk pass the VLAN 1 tagged and the VMware virtual switch receive them correctly.

enjoy!

.glitchlist crew

Comments 6

  1. Hello

    I have a question if i would like set up VMware 6.x HA (Two Server) with Cisco 3750X Stack
    How to config the switch?

    Thank you

    1. Post
      Author

      Hi Ya,
      Thanks for the question. As explained in the post you can use EtherChannel configuration on VmWare side and “channel-group [n] mode on” on Cisco Port-Channel side. I remain at your disposal for any further information.

      .glitchlist crew

      1. Hi .glitchlist crew
        Thank you so much for your information
        Do you mean configuration LACP vDS in ESX?

        Thank you
        Ya

      2. Post
        Author

        Yes, but pay attention on hashing algorithm that must be the same on physical switch and on vDS.

        🙂

        .glitchlist crew

      3. Hi glitchlist
        If i would like use Source and destination IP address, TCP/UDP port and VLAN in ESX
        What are commands in switch should I config ?

        Thank you

        Ya

      4. Post
        Author

        Hi Ya,
        on Cisco 3750X you can choose the followings LACP load balance methods:

        C3750X_LAB(config)#port-channel load-balance ?
        dst-ip Dst IP Addr
        dst-mac Dst Mac Addr
        src-dst-ip Src XOR Dst IP Addr
        src-dst-mac Src XOR Dst Mac Addr
        src-ip Src IP Addr
        src-mac Src Mac Addr

        I hope it helped.

        🙂

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.