Huawei & Nexus #subif #pingproblems

glitchlist Uncategorized Leave a Comment

Have you a Huawei NE series router and a Cisco Nexus switch? Do you have to enable communication between a router’s L3 sub-interface and a and the switch trunk? Yes? Ok, so this post is 4 you!

  1. in Huawei ARP broadcast is not enabled in sub-interfaces so a packet entering in the subif is discarded by the system beacause is considered as a blackhole route.
  2. Cisco & Huawei don’t have a good auto negotiation so you should set them manually on both side.

here you are:

HUAWEI:

#
interface GigabitEthernet0/5/0
 description to Switch
 undo negotiation auto
 speed 1000
 duplex full
 undo shutdown
 trap-threshold input-rate 1 resume-rate 1
 trap-threshold output-rate 1 resume-rate 1
 undo lldp enable
 undo dcn
#
interface GigabitEthernet0/5/0.15
 description to Switch * subif vlan 15
 ip address 192.168.15.10 255.255.255.0
 statistic enable
 encapsulation dot1q-termination
 dot1q termination vid 15
 arp broadcast enable
#


CISCO:

#
interface GigabitEthernet3/1
 description to Router
 no negotiation auto
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk alloweb vlan 5,10,15
 switchport mode trunk
#

enjoy!

.glitchlist crew

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.