802.3ad between Huawei AR2240 and Cisco 3750X

glitchlist Uncategorized Leave a Comment

IEEE 802.3ad is used to aggregate multiple link ethernet for increase the network speed and availability.
You can configure Layer3 to Layer3 LACP or Layer2 to Layer2 Etherchannel, but sometimes you have to do more:

Some routers like Huawei 2240 are only configurable in LACP Layer 3 mode but, for design requirements, the Core Switch (ex.: Cisco) have to be set in Porchannel Layer2 mode.

Here a little conf to configure an etherchannel between 2 Layer3 10G ports and 2 Layer2 10G ports:

# Huawei side:

interface Eth-Trunk20
 undo portswitch
 description LACP L3 to Switch L2
 ip binding vpn-instance testing-lab
 ip address 172.21.209.118 255.255.255.252
 mode lacp manual
#
interface XGigabitEthernet0/0/0
 eth-trunk 20
#
interface XGigabitEthernet0/0/1
 eth-trunk 20


# Cisco side:

interface Port-channel20
 description Etherchannel L2 to Router L3
 switchport access vlan 4
 switchport mode access
!
interface TenGigabitEthernet1/1/1
 switchport access vlan 4
 switchport mode access
 channel-group 20 mode on
!
interface TenGigabitEthernet1/1/2
 switchport access vlan 4
 switchport mode access
 channel-group 20 mode on
!

.glitchlist crew

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.